We have successfully monitored the system for a significant period of time and are confident that all issues have now been resolved. Thank you for your patience during this time
Posted Oct 20, 2025 - 11:09 UTC
Investigating
Currently, our Riskproof applications are experiencing some outages which means that you will be unable to receive emails & notifications from our system. We are working hard to establish the cause of this issue and find a resolution as soon as possible. We apologise for any inconvenience caused and any future updates will be posted on here.
Posted Oct 20, 2025 - 09:51 UTC
This incident affected: Mobile Application and Web Application.